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초기 설정

eclipse.ini

openFile
--launcher.appendVmargs
-vm
C:/eGovFrameDev-3.9.0-64bit/jdk1.8.0_202/bin/javaw.exe
-vmargs
-Dfile.encoding=UTF-8
...
-Xms512m
-Xmx2048m

eclipse

Pathtool 설정: 이클립스(Eclipse)1.
Springloaded 설정: Hot Deploy2.

javascript파일이 흑백으로 나올 때

Window > Preferences > General > Editors > File Associations

File types항목의 우측 버튼 Add 버튼 클릭

Define a New File Type 팝업 - File type에 .js 입력 - OK1.
입력 내용에 대해 .js 생성되고, 이것을 선택2.
하단의 Associated editors 항목에서 Generic Text Editor (locked by'JavaScript Source File'3.
content type)을 선택 후, 우측의 Default 버튼을 클릭 - 아래의 Apply and Close 버튼을 클릭

다시 javascript 파일을 열면, 코드에 컬러가 적용됨4.

Ref Link : [eclipse]이클립스 자바스크립트(js) 파일이 흑백으로 나올 때

http://rwiki.repia.com/doku.php?id=wiki:was:tomcat:hot_deploy
https://ssollacc.tistory.com/11
https://ssollacc.tistory.com/11
https://ssollacc.tistory.com/11
https://ssollacc.tistory.com/11
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사용자 정의 설정

* Eclipse File Search를 기본으로 설정하기

* Eclipse Quick Search
* Eclipse Label Decorations

서버(Server)

Resin 4.0 연동하기

Dynamic Web Project 구동시에 Run As → Run on Server 클릭시 Server 선택 창이 나타나지 않을 경우

Project에서 Mouse Right Click ⇒ Properties > Server → <None> 선택 후 Apply and Close
다시 구동하면 Server 선택 창이 나타날 것임.

python

eclipse에서 python 설정

Django 프로젝트 생성하기

플러그인

설치된 내역 확인 방법

Help >About Eclipse Platform > Installation Details > Installed Software

주요 플러그인

Eclipse Color Theme 1.0.0
Help > Install New Software - Available Software 팝업 > Add - Add Repository 팝업

name : Eclipse Color Theme & Location: http://eclipse-color-theme.github.io/update/
Top 12 Eclipse IDE Themes

Path Tools 1.0.64 (최신 버전(2020년 이후)에서는 수동으로 추가해야 됨)

수동 추가 방법

1. 플러그인 파일 복사
   ${기존 설치된 이클립스 경로}\eclipse\plugins\PathTools_1.0.67.jar,
PathToolsRSE_1.0.64.jar, PathToolsSubclipse_1.0.67.jar 를

   ${신규 설치된 이클립스 경로}\eclipse\plugins\ 로 복사한다.
2. 설정 파일 추가

http://rwiki.repia.com/doku.php?id=wiki:eclipse:eclipse_file_search%EB%A5%BC_%EA%B8%B0%EB%B3%B8%EC%9C%BC%EB%A1%9C_%EC%84%A4%EC%A0%95%ED%95%98%EA%B8%B0
http://rwiki.repia.com/doku.php?id=wiki:eclipse:eclipse_file_search%EB%A5%BC_%EA%B8%B0%EB%B3%B8%EC%9C%BC%EB%A1%9C_%EC%84%A4%EC%A0%95%ED%95%98%EA%B8%B0
http://rwiki.repia.com/doku.php?id=wiki:eclipse:eclipse_quick_search
http://rwiki.repia.com/doku.php?id=wiki:eclipse:eclipse_label_decorations
http://rwiki.repia.com/doku.php?id=wiki:eclipse:resin
http://rwiki.repia.com/doku.php?id=wiki:eclipse:resin
http://rwiki.repia.com/lib/exe/fetch.php?media=wiki:eclipse:server:eclipse_properties_server.png
http://rwiki.repia.com/doku.php?id=wiki:eclipse:eclipse%EC%97%90%EC%84%9C_python_%EC%84%A4%EC%A0%95
http://rwiki.repia.com/doku.php?id=wiki:eclipse:eclipse%EC%97%90%EC%84%9C_python_%EC%84%A4%EC%A0%95
http://rwiki.repia.com/doku.php?id=wiki:eclipse:eclipse%EC%97%90%EC%84%9C_python_%EC%84%A4%EC%A0%95
http://rwiki.repia.com/doku.php?id=wiki:eclipse:eclipse%EC%97%90%EC%84%9C_python_%EC%84%A4%EC%A0%95
http://rwiki.repia.com/doku.php?id=wiki:eclipse:django_%ED%94%84%EB%A1%9C%EC%A0%9D%ED%8A%B8_%EC%83%9D%EC%84%B1%ED%95%98%EA%B8%B0
http://rwiki.repia.com/doku.php?id=wiki:eclipse:django_%ED%94%84%EB%A1%9C%EC%A0%9D%ED%8A%B8_%EC%83%9D%EC%84%B1%ED%95%98%EA%B8%B0
https://www.tabnine.com/blog/top-eclipse-ide-themes/
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   ${신규 설치된 이클립스 경
로}\eclipse\configuration\org.eclipse.equinox.simpleconfigurator\bundles.info
파일에 아래 내용 추가한 후 재시작하면 된다.
#encoding=UTF-8
#version=1
PathTools,1.0.67,plugins/PathTools_1.0.67.jar,4,false
PathToolsRSE,1.0.64,plugins/PathToolsRSE_1.0.64.jar,4,false
PathToolsSubclipse,1.0.67,plugins/PathToolsSubclipse_1.0.67.jar,4,false

Autodetect Encoding
Remote System Explorer(SSH, Telnet, FTP and DStore protocols) 3.5.0
eXERD : Install New Software, http://exerd.com/update/3.x을 입력합니다.

Emmet(ex Zen-coding) : http://download.emmet.io/eclipse/updates/
웹개발 이클립스 플러그인 Emmet

Grep Console

편집, 주요 단축키

창 분할 가로: Ctrl + Shift + _
세로: Ctrl + Shift + {

주요 단축키 Top 30
[eclipse][TIP] 단기 속성으로 배우는 이클립스 상세 단축키 팁!
이클립스 단축키(화면이동)
Java IDE Eclipse에서 제일 많이쓰는 단축키 or 활용 Tip 함 보세요. ^^
블록단위 편집

Toggle Block Selection Mode (Alt + Shift + A)

Log

이클립스 워크벤치 or 프로그램이 오동작하거나, 반응이 없을 때 로그 파일은

${워크스페이스}/.metadata/.log 파일을 확인하자.

LOGGER

Logger 사용법

//  선언방법
private static final Logger Logger =
LoggerFactory.getLogger(Controller.class);
 
//  사용방법
Logger.debug("확인을 원하는 항목 = [{}]", 확인을 원하는 항목);

Logger 사용이유

http://exerd.com/update/3.x
http://download.emmet.io/eclipse/updates/
https://sas-study.tistory.com/158
https://sas-study.tistory.com/158
https://offbyone.tistory.com/315
http://rwiki.repia.com/doku.php?id=wiki:eclipse:shortcut
http://rwiki.repia.com/doku.php?id=wiki:eclipse:shortcut
https://seodaeya.tistory.com/90
https://seodaeya.tistory.com/90
https://lee-mandu.tistory.com/236?category=708588
https://ncanis.tistory.com/32
https://ncanis.tistory.com/32
https://ncanis.tistory.com/32
https://ncanis.tistory.com/32
https://ncanis.tistory.com/32
https://ncanis.tistory.com/32
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디버깅 작업시 걸리는 시간을 단축하기 위해 원하는 지점에서 확인 가능하도록 설정

큰 프로젝트 작업시에는 필수적으로 Logger를 사용하도록 해야함

기타

cdt
Tomcat Port Error
Export and Import
이클립스에서 원격으로 front를 작업하기

메이븐 저장소 변경하기

이클립스에서 SVN Ignore 적용방법

Maven lombok
Eclipse Decompiler
자동주석 설정

git연동

git 강제 Pull

Ref

eclipse설정 연동

이클립스 플러그인 수동 추가하는 법

이클립스에서 .properties파일의 유니코드를 한글로 바꾸기

기존에 Properties Editor가 인스톨 된 상태라면, 적용시키고싶은 파일 우클릭 후 Open With
통해서 재오픈 할 것.

이클립스에서 특정 확장자에 대한 오픈 에디터 설정하기

신규 프로젝트를 svn trunk에 업로드 하기

Tomcat Hot Deploy 설정 하기

컨트롤러 수정 후 바로 확인 가능(톰캣 재구동 없음)

eclipse validating 설정 해제 / build 속도 높히기

Top 30 Eclipse Keyboard Shortcuts for Java Programmers
이클립스 SERIALVERSIONUID 추가 방법

이클립스 사용법 및 TIP 정리

[이클립스 TIP] 블록단위 편집 : Toggle Block Selection Mode (Alt + Shift + A)
이클립스 validation 기능 off 하기

Tip

Tips and tricks
Using the dark theme

Zooming In and Out of Text with Eclipse
이클립스 블럭 주석 시 다중 * 제거 설정하기

 이클립스 우클릭 New목록 바꾸기

 이클립스 Open Resource 창에서 특정 파일 및 폴더 제외 방법

 [Eclipse_꿀팁(tips)] Ctrl+Space는 그만! 글자 입력하기만하면 Content Assist(자동완성기능)가
실행되는 방법!

http://rwiki.repia.com/doku.php?id=wiki:eclipse:cdt
http://rwiki.repia.com/doku.php?id=wiki:eclipse:tomcat_port_error
http://rwiki.repia.com/doku.php?id=wiki:eclipse:export_and_import
http://rwiki.repia.com/doku.php?id=wiki:eclipse:%EC%9D%B4%ED%81%B4%EB%A6%BD%EC%8A%A4%EC%97%90%EC%84%9C_%EC%9B%90%EA%B2%A9%EC%9C%BC%EB%A1%9C_front%EB%A5%BC_%EC%9E%91%EC%97%85%ED%95%98%EA%B8%B0
http://rwiki.repia.com/doku.php?id=wiki:eclipse:%EC%9D%B4%ED%81%B4%EB%A6%BD%EC%8A%A4%EC%97%90%EC%84%9C_%EC%9B%90%EA%B2%A9%EC%9C%BC%EB%A1%9C_front%EB%A5%BC_%EC%9E%91%EC%97%85%ED%95%98%EA%B8%B0
http://rwiki.repia.com/doku.php?id=wiki:eclipse:%EC%9D%B4%ED%81%B4%EB%A6%BD%EC%8A%A4%EC%97%90%EC%84%9C_%EC%9B%90%EA%B2%A9%EC%9C%BC%EB%A1%9C_front%EB%A5%BC_%EC%9E%91%EC%97%85%ED%95%98%EA%B8%B0
https://eclipse4j.tistory.com/275
http://rwiki.repia.com/doku.php?id=wiki:eclipse:%EC%9D%B4%ED%81%B4%EB%A6%BD%EC%8A%A4%EC%97%90%EC%84%9C_svn_ignore_%EC%A0%81%EC%9A%A9%EB%B0%A9%EB%B2%95
http://rwiki.repia.com/doku.php?id=wiki:eclipse:%EC%9D%B4%ED%81%B4%EB%A6%BD%EC%8A%A4%EC%97%90%EC%84%9C_svn_ignore_%EC%A0%81%EC%9A%A9%EB%B0%A9%EB%B2%95
http://rwiki.repia.com/doku.php?id=wiki:eclipse:%EC%9D%B4%ED%81%B4%EB%A6%BD%EC%8A%A4%EC%97%90%EC%84%9C_svn_ignore_%EC%A0%81%EC%9A%A9%EB%B0%A9%EB%B2%95
http://rwiki.repia.com/doku.php?id=wiki:eclipse:maven_lombok
http://rwiki.repia.com/doku.php?id=wiki:eclipse:eclipse_decompiler
http://rwiki.repia.com/doku.php?id=wiki:eclipse:%EC%9E%90%EB%8F%99%EC%A3%BC%EC%84%9D
http://rwiki.repia.com/doku.php?id=wiki:eclipse:git%EC%97%B0%EB%8F%99
http://rwiki.repia.com/doku.php?id=wiki:eclipse:git%EC%97%B0%EB%8F%99
http://rwiki.repia.com/doku.php?id=wiki:eclipse:gitforce
http://rwiki.repia.com/doku.php?id=wiki:eclipse:gitforce
http://rwiki.repia.com/doku.php?id=wiki:eclipse:gitforce
https://docs.google.com/document/d/1Umq8qY0AYhQJBwe-pEOBhfiZfa3Io3i6tR64Uif9S2w
https://docs.google.com/document/d/1Umq8qY0AYhQJBwe-pEOBhfiZfa3Io3i6tR64Uif9S2w
https://woo-yaa.tistory.com/7
https://dzzienki.tistory.com/37
https://dzzienki.tistory.com/37
https://dzzienki.tistory.com/37
https://mainia.tistory.com/1219
https://stormaa.tistory.com/18
https://stormaa.tistory.com/18
https://stormaa.tistory.com/18
https://aljjabaegi.tistory.com/243
https://aljjabaegi.tistory.com/243
https://gocoder.tistory.com/372
https://gocoder.tistory.com/372
https://gocoder.tistory.com/372
https://gocoder.tistory.com/372
https://javarevisited.blogspot.com/2018/07/top-30-eclipse-keyboard-shortcuts-java-programming.html
https://javafactory.tistory.com/1388
https://javafactory.tistory.com/1388
https://javafactory.tistory.com/1388
https://blog.naver.com/musasin84/220193278630
https://blog.naver.com/musasin84/220193278630
https://blog.naver.com/musasin84/220193278630
http://javaking75.blog.me/140212127352
http://javaking75.blog.me/140212127352
http://javaking75.blog.me/140212127352
http://javaking75.blog.me/140212127352
https://lee-mandu.tistory.com/448
https://lee-mandu.tistory.com/448
https://lee-mandu.tistory.com/448
https://lee-mandu.tistory.com/448
https://lee-mandu.tistory.com/448
https://help.eclipse.org/2019-12/index.jsp?topic=%2Forg.eclipse.platform.doc.user%2Ftips%2Fplatform_tips.html&cp%3D0_5
https://mcuoneclipse.com/2017/06/24/zooming-in-and-out-of-text-with-eclipse/
https://goodteacher.tistory.com/27
http://rwiki.repia.com/doku.php?id=wiki:eclipse:%EC%9D%B4%ED%81%B4%EB%A6%BD%EC%8A%A4_%EC%9A%B0%ED%81%B4%EB%A6%AD_new%EB%AA%A9%EB%A1%9D_%EB%B0%94%EA%BE%B8%EA%B8%B0
http://rwiki.repia.com/doku.php?id=wiki:eclipse:%EC%9D%B4%ED%81%B4%EB%A6%BD%EC%8A%A4_%EC%9A%B0%ED%81%B4%EB%A6%AD_new%EB%AA%A9%EB%A1%9D_%EB%B0%94%EA%BE%B8%EA%B8%B0
http://rwiki.repia.com/doku.php?id=wiki:eclipse:%EC%9D%B4%ED%81%B4%EB%A6%BD%EC%8A%A4_%EC%9A%B0%ED%81%B4%EB%A6%AD_new%EB%AA%A9%EB%A1%9D_%EB%B0%94%EA%BE%B8%EA%B8%B0
https://lng1982.tistory.com/208
https://lng1982.tistory.com/208
https://lng1982.tistory.com/208
https://devlimk1.tistory.com/9
https://devlimk1.tistory.com/9
https://devlimk1.tistory.com/9
https://devlimk1.tistory.com/9
https://devlimk1.tistory.com/9
https://devlimk1.tistory.com/9
https://devlimk1.tistory.com/9
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Troubleshooting

[Eclipse] Errors running builder "Integrated External Tool Builder" on project

이클립스 빌드시 아래와 같은 error 발생시

프로젝트에서 오른쪽 마우스 클릭 ⇒ properties(속성) ⇒ Builders 항목 ⇒ 엑박 builder 제거.

Eclipse에서 계속해서 오류날때 워크스페이스 Clean하기

Java 자동완성 (코드 힌트) 되지 않을 때 옵션 설정

Any way to get IntelliJ-like autocompletion in Eclipse?

[Errors] Default workspace is already in use. Do you want to choose another
worksapce?

이클립스 시작 시 상기 제목의 알림이 뜨는 경우

workspace > .metadata > .plugins > org.eclipse.e4.workbench > workbench.xmi 파일 삭제1.
이 방법만으로는 실패했음.

이클립스의 workspace > .metadata 폴더 > .lock 파일 삭제1.
이클립스 구동됨

[eGov 3.10] 자바스크립트 파일 컬러 설정 처리

자바스크립트 파일이 흑백으로 나올 경우

1. Window > Preferences > General > Editors > Fiel Associations

File types > Add 버튼 클릭 > .Js 추가1.
하단 Associated editors > Generic Text Editor 선택 > Apply and Close2.

위의 방법으로 안 될 경우
2. Help > Install New Software > Work with
- http://download.eclipse.org/releases/photon을 입력하고,

- 하단에 생성되는 목록 중에서 Web, XML, Java EE and OSGi Enterprise Development만 선택하여 설치
진행
- Window > Preferences > General > Editors > Fiel Associations에서 Associated editors - JavaScript
Editor를 default로 선택

https://blog.outsider.ne.kr/636
https://blog.outsider.ne.kr/636
https://blog.outsider.ne.kr/636
https://blog.outsider.ne.kr/636
https://m.blog.naver.com/PostView.naver?isHttpsRedirect=true&blogId=ambidext&logNo=221906522082
https://m.blog.naver.com/PostView.naver?isHttpsRedirect=true&blogId=ambidext&logNo=221906522082
https://stackoverflow.com/questions/5685257/any-way-to-get-intellij-like-autocompletion-in-eclipse/12349932#12349932
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Ref Link

Eclipse 자바스크립트 파일 컬러 설정 처리

Ref Link

[Eclipse]workspace 사용중으로 나와서 안열릴 때(eclipse please choose another workspace as is1.
currently in use
이클립스 Workspace 오류 - The default workspace is in use or cannot be create.2.
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